HOWTO: Gentoo java-1.5 (java 5.0) Probleme lösen

Wenn jemand sein System lang genug betreibt und nicht ständig neu installiert, dann kommt man nicht um Compileraktualisierungen herum.

In meinem Fall wurde java von der Version 1.4 auf die aktuelle java Version 1.0 (java 5.0) aktualisiert.

Leider schulg hier das Problem voll ein. Fast alle Javapakete auf dem System wurden mit der alten Java-Version 1.4 compeliert, aber der aktuelle Compiler benötigt die Pakete in der aktuellen Version.

Die Typische Fehlermeldung:

(Unsupported major.minor version 49.0)

Nach langem Suchen habe ich das Problem lösen können und biete jedem die Lösung:

Kurzfassung(falls die Programme auf eurem System bereits vorhanden sind):
#Prüft euer System auf alte Konfigurationsdateien:
/usr/bin/java-check-environment

#Sucht alle Pakete, die mit der alten Java-Version erstellt wurden und löst die Problem und Abhängigkeiten auf:
/usr/bin/java-1.5-fixer

Sollte das Programm zwischendurch abbrechen, weil ein Paket nicht compeliert werden konnte, dann ist meistens eine aktuelle Version des Paketes vorhanden und ihr sollt sie per Hand aktualisieren und das Programm erneut starten.
Dieser Fall traf bei mir bei struts ein, dass in der Version 1.2.8 installiert war, aber nur noch die Version 1.2.9 vorhanden war.

Die lange Fassung und ein paar sehr hilfreiche Erklärungen:

https://projects.gentooexperimental.org/expj/wiki/Using_migration-overlay
Falls noch weitere Probleme auftreten, sollte man im Gentoo Forum danach suchen: Unsupported major.minor

Die offizielle Java Upgrade Seite für Gentoo:

http://www.gentoo.org/proj/en/java/java-upgrade.xml

Vielen Dank an das Gentoo Team für die sehr hilfreiche und komfortable Lösung!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.