Beim Aufruf von run-app unter OpenJDK 6 und OpenJDK 7 kommt es zu Problemen mit Grails

Beim Aufruf von run-app für Grails aus der SpringSource Tools Suite (STS) habe ich auf einmal die folgende Fehlermeldung erhalten:

Error executing script RunApp: the number of constructors during runtime and compile time for java.lang.ClassLoader do not match. Expected 2 but got 3

Das Problem tritt nur mit OpenJDK auf. Stellt man den JDK auf die Sun-Version, so verschwindet der Fehler wieder und Grails funktioniert wieder. Die STS war bei der letzten Installation so frei sich die openjdk-Variante als JRE unter „Preferences -> Installed JREs“ zu wählen und nicht die von Sun.

Fehler behoben und weiter geht es!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.